Sorgenkind C16 springt automatisch in Monitor

  • Hallo zusammen.


    Habe vor längerer Zeit einen C16 von Schroeder bekommen, der auch immer brav gelaufen ist...bis gestern :traurig:

    Jetzt springt er direkt nach dem Einschalten in den Monitor.

    Komischerweise funktioniert er aber auf einmal wieder wenn beim Einschalten oder beim Reset drücken zusätzlich noch

    die Shift Lock Taste eingeschaltet ist....danach kann ich sie ausschalten, nochmal Reset drücken und der Kleine arbeitet wieder normal...:grübel:

    An der Tastatur selbst liegt es nicht - diese hatte ich abgehängt und trotzdem dieser merkwürdige Fehler :/

    Also tippe ich mal auf Char Rom / PLA.


    Hat da jemand schon einmal was ähnliches erlebt?


    Leider habe ich keinen kompletten Satz an Chips mehr (CPU,TED,PLA usw) um diese irgendwie gegeneinander zu tauschen und zu testen

    Falls jemand einen kompletten Satz verkaufen möchte wäre ich sehr dankbar, bzw gegebenenfalls den entsprechenden Chip.

    Versand meines C16 zur Prüfung wäre ebenfalls kein Problem...sämtliche Versandkosten würde ich übernehmen.


    Danke Euch im voraus für Eure Hilfe,

    Gruß Norman

  • Hi Peter,


    bin zwar noch auf Arbeit aber ich weiß das kein brauner IC verbaut ist...

    Trotzdem Danke für den Tip !

    Das würde aber bedeuten dass ich auf Hilfe angewiesen wäre weil meine Löt-Künste nicht die besten sind...:rotwerd:

  • Nur der Vollständigkeit halber: der macht das auch (in den Monitor springen) wenn kein Joystick angeschlossen ist?


    Gruß, Gerd

    Hallo Gerd,

    Ja das hat er trotzdem gemacht obwohl alles auser Strom in Antennekabel abgehängt waren...auch die Tastatur war nicht mehr angeschlossen...

    Wenn ein Commodore 8 Bit Rechner beim Reset nicht ins Basic springt, sondern in den Monitor,

    bedeutet das gewöhnlich, daß zwar das Kernal-ROM OK ist, es aber Probleme mit dem BASIC-ROM gibt.

    Kontrollier mal, ob das ROM in U3 evtl. Kontaktschwierigkeiten hat.

    Danke Dir, das werde ich morgen mal versuchen...

  • mal kurz in den Raum geworfen...


    Meine liebe Frau hat sich leider eine heftige Erkältung zugezogen und deswegen

    muss ich mich jetzt erst mal um sie kümmern bevor ich mich um das Sorgenkind C16 kümmern kann.

    Wahrscheinlich komme ich erst am Wochenende dazu.

    Trotzdem nochmal Danke für Eure Tips und ich werde baldmöglichst berichten.


    Gruß,

    Norman

  • Endlich Wochendene :)    
     
    Endlich habe / hatte ich mal Zeit mich mit dem Problem auseinander zu setzen.

    Kontrollier mal, ob das ROM in U3 evtl. Kontaktschwierigkeiten hat.

    Hi,


    Habe den Chip mal vorsichtig erntfernt, Kontakte gereinigt, den Sockel vorscichtig ausgeblasen und wieder eingesetzt

    aber leider hat es nichts gebracht.


    ist der 7406 für die Resetlogic so ein braunes IC? Wenn ja, sollte der getauscht werden. Evtl. hängt nämlich nur die Resetlogic.

    Hi Peter,

    habe mir das Board nochmal angeschaut aber dieser "ominöse braune" Chip ist nicht verbaut....

    Allerdings geht auch meine Vermutung in diese Richtung das diese Reset Logik Probleme macht.


    Nur der Vollständigkeit halber: der macht das auch (in den Monitor springen) wenn kein Joystick angeschlossen ist?

    Hi,

    Leider ja - selbst wenn das Board ohne angeschlossene Tastatur und Floppy, Datasette usw. läuft....



    Falls es also tatsächlich am 7406 Chip liegen sollte, wäre ich in diesem Fall wirklich auf externe Hilfe angewiesen :anbet:

    Meine Löt Erfahrungen beschränken sich wirklich nur auf ein Minimum :(

    Die Schaltregler Modifikation für die stabile Spannungsversorgung habe ich gerade noch so hinbekommen

    aber einen ganzen Chip zu ersetzen liegt auserhalb meiner bescheidenen Fähigkeiten :rotwerd:


    Es wäre also Herz allerliebst :love: wenn für mich jemand den sogenannten "Samariter spielt"

    und mir meinen geliebten C16 wieder heilen kann....:anbet:

    Bin auch bereit finanziell entgegen zu kommen....


    Zuletzt das Wichtigste !


    Das ganze hat keine Eile und muss nicht innerhalb weniger Tage passieren :prof:

    Trotzdem wäre ich über jede Hilfe dankbar damit ich wieder auf der geliebten kleine Kiste weiter hacken und daddeln kann <3


    Viele Grüße und schönes Wochendende :prost:

    Norman

  • Juhuu, hat sich erledigt :juchee:


    Habe einfach auf Verdacht einen U3 aus der Bucht für 4 Euronen bestellt....und siehe da, die Kiste funktioniert wieder einwandfrei.:thumbup:

    Danke Euch für die Hinweise :)

  • Sehr schön.


    Vor allem auch die Diagnosestellung - sehr punktgenau, Respekt.

    Was ich mich aber nun frage: Warum geht ein ROM einfach so kaputt. Ich hatte bisher immer gedacht, daß ein ROM das letzte ist, was in einem Rechner "einfach so" ausfällt.

  • Ich hab hier in einem 116 ein Eprom als Kernal und dort steht C16-U4 ZG2 drauf!

    Hat einer eine Idee was das bedeuten könnte?

    Vielleicht hat der Vorbesitzer ja den Kernal durch einen selbst gebrannten ausgetauscht ?

    Übrigens hätte man das defekte ROM auch durch ein 27128 EPROM ersetzen können, die passen direkt ohne Adpater rein

    Kannst du mir da vielleicht mal nähere Infos geben?

    Ich meine mal irgendwo gelesen zu haben das man die beiden Kernal U3 und U4 gegen stromsparendere Eproms austauschen kann um

    die Wärme Entwicklung im Gehäuse zu senken...war das im F64 ?

    Was ich mich aber nun frage: Warum geht ein ROM einfach so kaputt. Ich hatte bisher immer gedacht, daß ein ROM das letzte ist, was in einem Rechner "einfach so" ausfällt.

    Ja, ist eher ungewöhnlich aber nicht unmöglich...normalerweise sind TED,CPU und PLA die Kandidaten... CPU und TED waren bei mir schon mit einer passiven Kühlung versehen...jetzt hab ich dem PLA und den Kernals auch kleine Kühlköper verpasst....

  • Wenn es darum geht, die Wärme im C16 zu reduzieren, ist der Austausch der ROMs durch CMOS-EPROMs auf jeden Fall eine gute Maßnahme.

    Vor allem sollte man aber die Stromversorgung überarbeiten, denn die ist für einen Großteil der Wärmeabgabe des C16 verantwortlich.

    Die Schaltung wurde ohne Rücksicht auf Verluste auf möglichste geringe Produktionskosten optimiert und war auch nach damaligem Stand der Technik durchaus fragwürdig.

    Die Lösung mit der geringsten Wärmeentwicklung wäre ein Umbau auf ein externes Netzteil, das den Rechner direkt mit +5V versorgt.

    Der Nachteil daran ist, daß der Anschluß des Originalnetzteils dann aber den Rechner beschädigen würde.

    Ein guter Kompromiss ist, den verbauten Längsregler und den parallelgeschalteten Zementwiderstand durch einen (hochwertigen) Schaltregler zu ersetzen.

    Das reduziert die Abwärme auch erheblich, und das Originalnetzteil kann weiterverwendet werden.

  • Dazu kommt, dass der Spannungsabfall am Zementwiderstand bei jeder Reduzierung der Stromaufnahme abnimmt. Wann dann der Längsregler gegenüber den Widerstand aufgibt? Längsregler mögen in der Regel keine Ausgansspannung die die Eingangspannung übersteigt.

  • Die ROM-Lebensdauer ist sehr unterschiedlich und hängt auch von der Verwendung ab.

    Ich hab zum Beispiel schon viele defekte C64-Char-ROMs gehabt.

    Das Char-Rom wird ja auch permanent verwendet um das Bild aufzubauen - da geht es natürlich auch schneller kaputt.

    Die 2316 Roms in den alten PETs gehen auch gern mal kaputt.

  • Das mit dem Schaltregler Umbau habe ich schon vor längerer Zeit gemacht.

    Das hat mit meinen bescheiden Löt Erfahrungen sogar sehr gut geklappt....jedoch beim auslöten eines ganzen IC's wäre es für mich etwas komplizierter geworden.

    Das original Netzteil wurde gegen ein stärkeres Universal Netzteil getauscht.


    meine Frage wäre jetzt woher ich die CMOS Eproms beziehen könnte, oder ob die von mir verbauten Kühlkörper ausreichen.