8028 - Druckwagen fährt stets vollständig nach rechts

  • Hallo,


    wollte heute meinen CBM 8028 mal wieder laufen lassen aber: Beim Einschalten fährt der Druckwagen ganz nach rechts. Der Motor schaltet auch bei erreichen des Anschlages nicht ab.;(


    Meines Wissens "sieht" der 8028 beim Start nach, wo der linke Papierrand beginnt. Dafür gibt es auch eine Reflexionslichtschranke am Druckwagen


    Beim Zerlegen ist mir aufgefallen, dass auf dem Digitalboard zwei Adapterplatinen (6532 mit 2716 EPROM). Eines davon ist mit DSY-06 (Typenrad - nehme ich an) , das andere mit CAR-06 (Druckwagen - nehme ich an) beschriftet. Ich habe beide ROMs ausgelesen und mit den .bin von Bo Zimmerman verglichen - passt. Das andere ROM ist ein 2564, dass kann ich leider nicht auslesen. Mein Eprommer mag nur 27xxx und 2532er..... :nixwiss:


    Jetzt die große Frage: Es scheint, als ob der linke Papierrand nicht erkannt wird und der Wagen deshalb nach rechts fährt (aber sollte er dann nicht ganz rechts stoppen?). Gibt es zu diesem Gerät Erfahrungen mit der Lichtschranke oder liegt der Fehler auf dem Digitalboard (6532er, ROMs, Sockel,...) , oder auf der anderen Platine??


    Hat jemand Erfahrungen mit diesem Fehlerbild. Tipps wären echt nett.

  • So, heute mal den Signalweg bis zum 6522-2 (UA2) in den Serviceunterlagen verfolgt.


    Emitter (Fototransistor) --> Kontakt B10 --> Stecker YB2 --> Pin 7 (IC 801, CD 4049) - hier R 805 und C802 auf Kurzschluss prüfen! - Pin 6 (IC 801) --> Pin F an Stecker J2 (HOME) --> Pin 8 (PA6) an UA2 (6522).


    Mal sehen, was der Signalverlauf so sagt (Im Moment gilt meine Verdacht C 802 und IC 801 - na, mal sehen)


    Edit: In den Serviceunterlagen steht bei EPROM UA5: 2574/ 2764 - öh?? Sind die nicht irgendwie unterschiedlich beim Pinout??

    Außerdem sind weichen die doch auch gegenüber dem 2364 ab, so dass man diese (verbreiteten) Adapter nicht verwenden kann.

    <--- Das da ist eine Hälfte meines Ichs

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Eloy_Dorian () aus folgendem Grund: Frage zum EPROM-Gedöns vergessen.

  • Emitter (Fototransistor) --> Kontakt B10 --> Stecker YB2 --> Pin 7 (IC 801, CD 4049) - hier R 805 und C802 auf Kurzschluss prüfen! - Pin 6 (IC 801) --> Pin F an Stecker J2 (HOME) --> Pin 8 (PA6) an UA2 (6522).

    So kommts, wenn man nicht richtig liest. Der Weg beschreibt die Erkennung des Linksanschlages.


    Papierendesensor heißt das Zauberwort: Stecker XB2 (B9) --> Pin 5 des IC 801 (CD 4049) --> Pin 2 --> Signal PAED --> J2 (Pin 7) --> UA2 (6522) auf Pin 3 (PA1).


    Wichtig: Messen, ob die +5V da sind.


    Außerdem Adaptersockel gelötet und das M 07 A.bin auf ein 2764 gebrutzelt. Außerdem zwei 2716er mit CAR 06.bin und DSY 06.bin versorgt.


    Bin schon gespannt, wie es weiter geht.

  • So, Zwischenbericht:


    Fototransistor funktioniert --> Kontakt XB2 (B9) vorhanden --> Versorgungsspannung IC 801 ok --> Signal PAED wird generiert (5V bei Paper out und 0V bei Paper in) - SIgnal liegt an UA2 auf Pin 3 an.


    So und jetzt?


    Ich werde den 6522 mal quertauschen, vielleicht mag der nicht mehr so richtig.


    Irgendwo sollte doch ein Signal vom Digitalboard auf das Analogboard gehen und dem Druckwagenmotor sagen "Bursch! anhalten"

  • bitte überprüfe direkt am 6522-2 ua2 pin8 das home signal.


    gruß

    helmut


    edit...von wem ist das 8028 service manual?

    mir kommt irgendwie die schrift der notizen, im schaltplan, bekannt vor.

  • Irgendwo sollte doch ein Signal vom Digitalboard auf das Analogboard gehen und dem Druckwagenmotor sagen "Bursch! anhalten"

    fast alle drucker haben keine kopf am ende erkennung.

    nur für den anfang eine "home" erkennung für den linken rand.


    alle drucker fahren den druckkopf, nach dem einschalten, zuerst nach links.

    bis sie ein signal vom linken kontakt / lichtschranke bekommen,

    dann fahren sie ein stück nach rechts bis kontakt / lichtschranke wieder frei ist.

    das ist dann die zeilen home position.


    schiebe bitte den druckkopf in die mitte.

    wenn er nach dem einschalten sofort nach rechts fährt, glaubt er schon links zu sein

    und möchte somit den linken kontakt / die lichtschranke freigeben und das funktioniert bei deinem drucker nicht.


    gruß

    helmut

  • Hallo axorp ,


    ganz ganz herzlichen Dank für den Tipp:streichel:. Der war goldrichtig! Habe zunächst die Pegel an IC 801 gemessen - hier keine Veränderung, egal ob Lichtschranke unterbrochen oder nicht.R 805 und C802 gemessen - kein Kurzschluss. Dann am Platinenstecker YB2 Pin B10 - ebenfalls keine Pegelveränderung.

    Dann direkt an den Pins des Fototransistors gemessen - Zustand Unterbrochen - Nicht unterbrochen wird erfasst. Lötstellen nachgelötet --> Der Drucker tut wieder.:vivat::juchee:


    Du bist klasse :anbet:! Bin Dir was schuldig :prost:.


    Gruß



    Stefan

  • Das Service Manual stammt von Dir selbst, Helmut.

    Ich hab's eingescannt und im Forum hochgeladen.

    aha, deswegen kam mir diese schrift irgendwie bekannt vor.

    nun bin ich mir sicher, es war wohl mein techniker thomas griesecke.

    wo der wohl steckt? er war der drucker und floppy spezialist.


    gruß

    helmut