Netzteil C64 selbst gebaut

  • Hi,


    ich habe mir aus einem 5 V Schaltnetzteil und einem 9 V Trafo ein (Ersatz)-Netzteil für den C64 gebaut. Die 5 V stimmen genau (gemessen 5,01 V) aber statt 9 V gibt der Trafo 11,5 V im Leerlauf und bei ca, 0,5 A Last immer noch 10,8 V. Genommen habe ich den hier:

    https://www.pollin.de/p/printtrafo-hahn-08w41-300532

    Printtrafo HAHN 08W41

    Eingang 230 V - Ausgang 9 V/1111 mA/10 VA - Maße (LxBxH): 65x42x35 mm


    Ist das noch OK für den C64? Oder sollte ich da noch einen Lastwiderstand dazwischen schalten, damit das näher an die 9V kommt?


    Gruß, Jochen


  • Die Schaltung ist sehr einfach: Netzspannung an die Primärseite des Trafos, an die beiden anderen Pins das Kabel zum C64. Ich würde den Trafo an liebsten zurückschicken, aber die Pins sind ja schon verlötet. Der Trafo hat auch nur 4 Pins, die anderen sind vergossen. Für die +12 V im C64 ist das egal, die werden ja mit einem 7812 geregelt - wenn der mehr Spannung bekommt, wird er wärmer, sonst nichts. Aber die 9 V gehen noch auf die Datasette und an die CIA - Datasette ist unkritisch aber die CIA könnte das übelnehmen. Schon krass das ein Trafo soweit außerhalb seiner Spezifikation arbeitet.

  • Anrufen könnte ich ja tatsächlich mal. Auf der anderen Seite ist das NT fertig aufgebaut und ich baue es nur ungern wieder auseinander. Wenn ich in den 9 V-Zweig einen 10 Watt-Lastwiderstand hänge, der die 20% verbrät, ist das deutlich weniger Aufwand.

  • Ich habe bei Pollin angerufen und den Sachverhalt geschildert. Ich kann die Trafos zurückschicken - trotz Lötzinnspuren an den Beinchen. Also nehme ich meinen Lötkolben und warte, bis er heiß genug ist...und warte...und warte länger... prüfe die Temperatur mit dem Finger - zucke NICHT laut schreiend zurück, der Lötkolben ist gerademal lauwarm. Steckdose hat Spannung, Kabel ist OK, Widerstand des Heizelements: unendlich. Mist. Gerade jetzt macht mein letzter Lötkolben die Grätsche. In 3 Tagen läuft die Rücksendefrist ab. OK, ich habe noch einen Gaslöter, frisch befüllt, gezündet und vorsichtig auf einen Pin gezielt. Keine gute Idee: die Kabelisolierung fängt sofort Feuer, es qualmt und stinkt - so geht das nicht. Aber den Lötkolben kann man damit heiß machen. Das reicht dann für 2 Lötpunkte, dann wieder in der Gasflamme aufwärmen. Sind ja nur 12 Verbindungen. So habe ich die Trafos schließlich doch noch herausbekommen. Für die Dauer ist mir das aber zu umständlich, ein neuer Lötkolben muss her.

  • Ja, es wird eine Lötstation werden. Die sind ja echt spottbillig geworden. Werde aber nicht die allerbilligste nehmen. Ich schwanke noch, ob ich eine Lötstation mit digitaler Temperaturanzeige will (BRAUCHEN tue ich sie nicht). Bei Pearl habe ich eine für etwa 25 Euro mit 5 Ersatzspitzen gesehen - die kommt in die engere Wahl.